Localization Issues
Incident Report for PBS Public Status
Resolved
This incident is now resolved.
Posted Nov 19, 2024 - 17:18 EST
Investigating
We are currently investigating issues with localization on pbs.org. In some cases the wrong station localization may be displayed in some parts of the website.
Posted Nov 19, 2024 - 12:30 EST
This incident affected: PBS Website.