Outage - Errors on the PBS App and when playing videos on pbs.org

Incident Report for PBS Public Status

Monitoring

A fix has been implemented. Normal functioning has been restored to the PBS App, pbs.org, and station video portals.
We will continue to monitor in case any further mitigation is needed.
Posted Sep 04, 2026 - 04:12 EDT

Investigating

Our engineering team is currently investigating reports of errors loading the PBS App on all platforms and playing videos on pbs.org.
Posted Sep 04, 2026 - 02:53 EDT
This incident affects: PBS Website, PBS Video Portal, PBS Partner Player, and PBS Mobile and OTT Apps.